Bullzip.PDFPrinterSettings Interface

Methods

Init
LoadSettings
WriteSettings
RemoveSettings
SetValue
GetValue

Properties

None

Back to the Component Reference
Copyright Bullzip 2007


Methods of Bullzip.PDFPrinterSettings

Bullzip Online Documentation

Methods

Init
LoadSettings
WriteSettings
RemoveSettings
SetValue
GetValue

Back to the Interface Reference
Copyright Bullzip 2007


GetValue Function

Get the current value of a particular setting.

Declaration

Public Function GetValue(configname As String) As String

Arguments

configname
Name of the configuration to get.

Remark

None.

See Also

SetValue

Applies To: Bullzip.PDFPrinterSettings

Methods

Copyright Bullzip 2007


Init Sub

Initialize the component.

Declaration

Public Sub Init()

Remark

You can call this function to reset the component to the initial state.

Applies To: Bullzip.PDFPrinterSettings

Methods

Copyright Bullzip 2007


LoadSettings Sub

Read the existing settings.ini or runonce.ini into memory.

Declaration

Public Sub LoadSettings(Optional isRunOnce As Boolean = True)

Arguments

isRunOnce
A boolean value that indicates if you are trying to load the runonce.ini or the settings.ini file. If this parameter is TRUE it will load the runonce.ini. Otherwise, the settings.ini is loaded. This parameter is optional and the default value is TRUE.

Remark

If errors occur during the load an empty configuration will be the result. This means that you don't have to know if a configuration exists before you try to load it.

See Also

WriteSettings | RemoveSettings

Applies To: Bullzip.PDFPrinterSettings

Methods

Copyright Bullzip 2007


RemoveSettings Sub

Removes an existing settings.ini or runonce.ini

Declaration

Public Sub RemoveSettings(Optional isRunOnce As Boolean = True)

Arguments

isRunOnce
Optional boolean value that indicates if you are working on the runonce.ini or settings.ini file. The default value is TRUE, which will work on the runonce.ini.

Remark

If the file you are trying to delete doesn't exist, nothing will happen.

See Also

LoadSettings | WriteSettings

Applies To: Bullzip.PDFPrinterSettings

Methods

Copyright Bullzip 2007


SetValue Sub

Set a value in the configuration.

Declaration

Public Sub SetValue(configname As String, configvalue As String)

Arguments

configname
Name of the configuration to set.

configvalue
Value of the configuration.

Remark

A call to this function can be used to change all the printer settings such as the output path. Changing the output would look something like SetValue("output", "c:\myfile.pdf").

See Also

GetValue

Applies To: Bullzip.PDFPrinterSettings

Methods

Copyright Bullzip 2007


WriteSettings Sub

Save the settings to the runonce.ini or settings.ini file.

Declaration

Public Sub WriteSettings(Optional isRunOnce As Boolean = True)

Arguments

isRunOnce
Optional boolean value that indicates if you are working on the runonce.ini or settings.ini file. The default value is TRUE, which will work on the runonce.ini.

Remark

An error is raised if the write operation fails.

See Also

LoadSettings | RemoveSettings

Applies To: Bullzip.PDFPrinterSettings

Methods

Copyright Bullzip 2007


PDF Printer

Bullzip Online Documentation

Reference for the PDF Printer DLL

Interfaces

Bullzip.PDFPrinterSettings
Copyright Bullzip 2007